Page 1 of 5 1 2 3 4 5 LastLast
Results 1 to 10 of 42

Thread: Onan 5500 issues running reading codes and parts

  1. Print this Post   #1
    August 29, 2018 porthole's Avatar
    Join Date
    Apr 2009
    Location
    USA - NJ
    Posts
    10,879

    Onan 5500 issues running reading codes and parts

    I run Valvtec Ethanol Marine treatment and stabilizer in the Cyclones fuel tank - all the time. The fuel gets used throughout the tow season and a fresh tank is added coming home from the last trip of the year. In the spring all the fuel is pumped into the mower (holds 11 gallons) 5 gallon jugs and the remainder goes in the car. Then fresh fuel added to the Cyclone, with treatment.

    Once a month the genny is started, allowed to warm up then run for about 30 minutes under a load, 2 heat strips in AC units and a 1500 watt Pelonis. A 5 minute cool down period and then shut down. I figure this is about the best you can do with a gasoline generator. I do the same with my Honda 3000.

    Night before leaving for a week of boon-docking at Dover the Onan would not run well. Changed the fuel filter and called it a night. From past experience I learned that if you have a good portable genny and the means to bring it along, you may as well, so the Honda was already in the trailer.

    At Dover - 90 degrees and the Onan runs poor. Bad enough with "hunting" and shutting down that I thought it may have damaged our main AC (another thread). Great, 1st day of a week trip and 1 AC down and 1 generator down, both primary units.

    Used the bedroom AC, the Honda and 2 12 volt portable Fantastic fans. The trailer already has multiple 12 volt outlets added for areas where we can't run genny's.

    The Onan throws codes for certain issues. Removing the cover gains access to a manual switch and circuit breakers. The switch may or may not be flashing red.

    If flashing it should be 3 flashes followed by a pause. This indicates a stored fault code. one push of the switch will generate the sequence. For example; 3 flashes - pause - 6 flashes - for a code 36. This will repeat until you press the switch again, which will clear the stored codes.

    If the switch is not flashing but there are stored codes you press the switch off 3 times, then the codes will start.

    36 is a common code and the list of troubleshooting is long and pretty much covers every possible outcome. Including a fuel control solenoid replacement.

    I want to take the carb apart and look inside. Turns out there are 2 Onan dealers within 5 miles of Dover Speedway.

    Both dealers gave me pretty much the same information.
    Mine is a common problem.
    Onan no longer supplies any carb related parts, e.g. the gaskets and the fuel control solenoid.
    You can now only buy a complete carb assembly for $250.

    One of the dealers suggested that if the jets were clogged one way to help clear it would be to get it running a full speed and manually close the choke, forcing the pulling of fuel through the jets and vents. Reminds me of one of the tricks we use to do back in the late 70's, early 80's when fuel started to cause havoc with automobile carbs.

    Neither dealer knew anything about any recall on the fuel pump when I gave them the number.

    Back to the trailer to try once again. The Onan starts and runs great for the next 8 hours. Same thing the next day.
    3rd day it acts up, will not come up to speed, sputters and stalls etc.

    One of the steps for code 36 is replacing the fuel control solenoid, you can't buy one so I did the next best thing - rapped it with a wrench several times. Runs smooth as butter now. Ran good for 2 days and acted up on the last day. Rapped the solenoid once again and it ran smooth.
    Last edited by porthole; 11-29-2014 at 07:57 AM. Reason: spelling
    Duane & Debbie with Regis & Baylee
    RIP camping buddies Cagney, Misty, my Molly & Gungy
    2011 F-350 DRW

    Rallies & campouts:
    2009
    - 1
    2010
    - 5
    2011
    - 6
    2012 - 7
    2013 - 8
    2014 - 9
    2015 - 8
    2016 - 8
    2017 - 9
    2018 - 8 so far

    Mods
    --- Topic index --- TST TPMS --- SAT TV --- Onan issues --- Hensley TS-3 :-( --- Ramp failure

  2. Print this Post   #2
    Moderator danemayer's Avatar
    Join Date
    Jul 2010
    Location
    USA - CO
    Posts
    18,814

    Re: Onan 5500 issues running reading codes and parts

    A time tested technique. When all else fails, pull out the 16 ounce "persuader".


    Sent from my iPad using Tapatalk HD


    Dan and Ann Mayer & fur baby Callie the Rally Dog
    2011 Landmark Rushmore
    • MorRyde 8K Independent Suspension
    • 8K Kodiak Disc Brakes
    • RV Comfort Systems Cheap Heat
    • MorRyde 33x90 Sliding Cargo Tray
    • Torklift Glowstep Revolution Aluminum Steps & Dirt Destroyer

    2014 RAM 3500 Laramie
    • Cummins 6.7 Diesel, AISIN Transmission
    • 4x4, Long box, Crew Cab, DRW 3.73
    • Hensley BD3 TrailerSaver Hitch
    • Garmin RV760 GPS


    Is club membership right for you? Click here to learn more

    Check out our Owner-written User Guides and Troubleshooting Guides

  3. Print this Post   #3
    August 29, 2018 porthole's Avatar
    Join Date
    Apr 2009
    Location
    USA - NJ
    Posts
    10,879

    Re: Onan 5500 issues running reading codes and parts

    Here is the solenoid, silver object with the two white wires coming out the bottom.

    BTW, older 5500's have two fuel filters, same filter, so the 2nd is really useless. Onan has since bypassed it.
    If you have a 2 filter model there is a replacement fitting to remove it, part number A026E529

    In the same picture, the adapter is the silver object with red paint on it, rubber hose attached to the bottom.
    This is where the 2nd filter would be if equipped.

    The solenoid is above and to the left of the yellow plug, white connector on the bottom of it.
    Attached Images Attached Images
    Last edited by porthole; 11-29-2014 at 07:59 AM.
    Duane & Debbie with Regis & Baylee
    RIP camping buddies Cagney, Misty, my Molly & Gungy
    2011 F-350 DRW

    Rallies & campouts:
    2009
    - 1
    2010
    - 5
    2011
    - 6
    2012 - 7
    2013 - 8
    2014 - 9
    2015 - 8
    2016 - 8
    2017 - 9
    2018 - 8 so far

    Mods
    --- Topic index --- TST TPMS --- SAT TV --- Onan issues --- Hensley TS-3 :-( --- Ramp failure

  4. Print this Post   #4
    Senior Member Sandpirate69's Avatar
    Join Date
    May 2011
    Location
    USA - FL
    Posts
    367

    Re: Onan 5500 issues running reading codes and parts

    But would that solenoid cause the surging? I can see how the ethanol deteriorates fuel lines & cause main or idle jets to get clogged. But it runs awsome under load. So I'm a bit stumped by it.



    Roiz Family

    Ivan, Margarita, Gabriela, Isabella, & Rocky (doggie heaven 05/24/14)
    2002 Chevrolet 2500 HD 6.0L/ 45 gallon Transfer Flo/ Bully Dog GT Tuner (Retired)
    2008 Chevrolet 3500 LTZ 6.6 Duramax/Allison DRW , Reese 18K Elite Hitch, Line-X , Mike L Tranny Cooler
    4" MagnaFlo SS Exhaust, 3" MagnaFlo DP, Edge CTS Monitor, Nicktane Fuel Filter w/CAT Filter, EGR Blocked, PCV Rerouted, EFI Live DSP5, TransGo jr, Airdog 165
    2011 Road Warrior 305W/ Trail Air TriGlide / TST 507 Tire Monitor
    1993 FLSTF (FatBoy) Custom
    2004 Polaris ATP 500 Camo
    OIF/OEF US Navy Veteran

  5. Print this Post   #5
    August 29, 2018 porthole's Avatar
    Join Date
    Apr 2009
    Location
    USA - NJ
    Posts
    10,879

    Re: Onan 5500 issues running reading codes and parts

    Quote Originally Posted by Sandpirate69 View Post
    But would that solenoid cause the surging?

    Yes it does. Under no load the genny could be drawing just enough fuel past any sticking plunger or debris to run, surging, hunting etc.
    Under a load, the fuel draw may be enough to overcome a sticking plunger.

    Either way with your issue (same symptoms as mine) doesn't cost anything to try.

    I was ready to buy a $250 carb assembly at Dover last year until I tried the "rap" method.
    Duane & Debbie with Regis & Baylee
    RIP camping buddies Cagney, Misty, my Molly & Gungy
    2011 F-350 DRW

    Rallies & campouts:
    2009
    - 1
    2010
    - 5
    2011
    - 6
    2012 - 7
    2013 - 8
    2014 - 9
    2015 - 8
    2016 - 8
    2017 - 9
    2018 - 8 so far

    Mods
    --- Topic index --- TST TPMS --- SAT TV --- Onan issues --- Hensley TS-3 :-( --- Ramp failure

  6. Print this Post   #6
    Senior Member Sandpirate69's Avatar
    Join Date
    May 2011
    Location
    USA - FL
    Posts
    367

    Re: Onan 5500 issues running reading codes and parts

    "Rap" please explain this procedure. Rap to me means hit it with something to dislodge. Not sure if that's what you mean by "Rap". Please advise
    Thank you



    Roiz Family

    Ivan, Margarita, Gabriela, Isabella, & Rocky (doggie heaven 05/24/14)
    2002 Chevrolet 2500 HD 6.0L/ 45 gallon Transfer Flo/ Bully Dog GT Tuner (Retired)
    2008 Chevrolet 3500 LTZ 6.6 Duramax/Allison DRW , Reese 18K Elite Hitch, Line-X , Mike L Tranny Cooler
    4" MagnaFlo SS Exhaust, 3" MagnaFlo DP, Edge CTS Monitor, Nicktane Fuel Filter w/CAT Filter, EGR Blocked, PCV Rerouted, EFI Live DSP5, TransGo jr, Airdog 165
    2011 Road Warrior 305W/ Trail Air TriGlide / TST 507 Tire Monitor
    1993 FLSTF (FatBoy) Custom
    2004 Polaris ATP 500 Camo
    OIF/OEF US Navy Veteran

  7. Print this Post   #7
    August 29, 2018 porthole's Avatar
    Join Date
    Apr 2009
    Location
    USA - NJ
    Posts
    10,879

    Re: Onan 5500 issues running reading codes and parts

    Quote Originally Posted by Sandpirate69 View Post
    "Rap" please explain this procedure. Rap to me means hit it with something to dislodge. Not sure if that's what you mean by "Rap". Please advise
    Thank you

    Tap the side of the solenoid with a solid object while it is running, preferably when it is not running correctly.
    I used the same wrench I had out to replace the fuel filter.
    Duane & Debbie with Regis & Baylee
    RIP camping buddies Cagney, Misty, my Molly & Gungy
    2011 F-350 DRW

    Rallies & campouts:
    2009
    - 1
    2010
    - 5
    2011
    - 6
    2012 - 7
    2013 - 8
    2014 - 9
    2015 - 8
    2016 - 8
    2017 - 9
    2018 - 8 so far

    Mods
    --- Topic index --- TST TPMS --- SAT TV --- Onan issues --- Hensley TS-3 :-( --- Ramp failure

  8. Print this Post   #8
    Senior Member Sandpirate69's Avatar
    Join Date
    May 2011
    Location
    USA - FL
    Posts
    367

    Re: Onan 5500 issues running reading codes and parts

    Ok. I will try it when it starts to pulsating. Thanks for the info



    Roiz Family

    Ivan, Margarita, Gabriela, Isabella, & Rocky (doggie heaven 05/24/14)
    2002 Chevrolet 2500 HD 6.0L/ 45 gallon Transfer Flo/ Bully Dog GT Tuner (Retired)
    2008 Chevrolet 3500 LTZ 6.6 Duramax/Allison DRW , Reese 18K Elite Hitch, Line-X , Mike L Tranny Cooler
    4" MagnaFlo SS Exhaust, 3" MagnaFlo DP, Edge CTS Monitor, Nicktane Fuel Filter w/CAT Filter, EGR Blocked, PCV Rerouted, EFI Live DSP5, TransGo jr, Airdog 165
    2011 Road Warrior 305W/ Trail Air TriGlide / TST 507 Tire Monitor
    1993 FLSTF (FatBoy) Custom
    2004 Polaris ATP 500 Camo
    OIF/OEF US Navy Veteran

  9. Print this Post   #9

    Re: Onan 5500 issues running reading codes and parts

    I ran mine yesterday, under no load it ran for 2-3 minutes then started surging up and down until finally stalling. Until then it ran smooth. I've noticed the gas is very yellow looking. It came from texas, I was thinking it was an ethanol colored gas. Would an 09 Onan show codes as described with the off switch? That way if no codes are shown, I'll remove the fuel and replace the filter and see if it helps. It's hard to run it under a good load now, winters here, the ac units are covered in snow. One other thing, my fuel gauge has never worked, always on empty. Anyone else had this problem?

  10. Print this Post   #10
    August 29, 2018 porthole's Avatar
    Join Date
    Apr 2009
    Location
    USA - NJ
    Posts
    10,879

    Re: Onan 5500 issues running reading codes and parts

    If you don't know the condition - age of your fuel, I would dump all of it.
    Start with a fresh tank, add SeaFoam treatment and perhaps ValvTec's ethanol fuel treatment.

    Get the genny running, then put it under a load, use electric heaters, at least one on each leg.
    Run for about an hour.

    When time is up, turn off all loads and let genny run on a cool down mode for 5 minutes.
    Duane & Debbie with Regis & Baylee
    RIP camping buddies Cagney, Misty, my Molly & Gungy
    2011 F-350 DRW

    Rallies & campouts:
    2009
    - 1
    2010
    - 5
    2011
    - 6
    2012 - 7
    2013 - 8
    2014 - 9
    2015 - 8
    2016 - 8
    2017 - 9
    2018 - 8 so far

    Mods
    --- Topic index --- TST TPMS --- SAT TV --- Onan issues --- Hensley TS-3 :-( --- Ramp failure

Page 1 of 5 1 2 3 4 5 LastLast

Similar Threads

  1. Onan 5500 not running good
    By JOwen72 in forum Generators / Transfer Switches (ATS)
    Replies: 9
    Last Post: 05-22-2014, 09:17 AM
  2. My Onan 5500...HOT!!
    By wingfoot in forum Generators / Transfer Switches (ATS)
    Replies: 17
    Last Post: 08-11-2011, 12:46 PM
  3. Onan 5500 will not stay running.
    By timsitis in forum Generators / Transfer Switches (ATS)
    Replies: 14
    Last Post: 07-28-2011, 11:16 AM
  4. Onan 5500
    By Barry Crocker in forum Generators / Transfer Switches (ATS)
    Replies: 3
    Last Post: 02-07-2011, 07:47 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •